之前一直使用的是 Nginx 官方源,现在服务器配置了 HTTP2, 需要 ALPN 的支持。官方源的 Nginx 中的 OpenSSL 是老版本, OpenSSL 1.0.2 才开始支持 ALPN, 所以需要自己编译 Nginx。

基本步骤:

  1. 下载解压最新版 Nginx 和 OpenSSL ,放在同一个目录,如果是 16.04 以上的 Ubuntu , 就不需要下载 OpenSSL 了;
  2. 进入 Nginx 源码目录,执行下面的命令。
# 安装编译依赖
apt-get install build-essential libpcre3-dev  zlib1g-dev libxslt1-dev

# 配置 with-openssl 指向 OpenSSL 源码所在目录
./configure --with-openssl=../openssl-1.1.0b --prefix=/etc/nginx --sbin-path=/usr/sbin/nginx --modules-path=/usr/lib/nginx/modules --conf-path=/etc/nginx/nginx.conf --error-log-path=/var/log/nginx/error.log --http-log-path=/var/log/nginx/access.log --pid-path=/var/run/nginx.pid --lock-path=/var/run/nginx.lock --http-client-body-temp-path=/var/cache/nginx/client_temp --http-proxy-temp-path=/var/cache/nginx/proxy_temp --http-fastcgi-temp-path=/var/cache/nginx/fastcgi_temp --http-uwsgi-temp-path=/var/cache/nginx/uwsgi_temp --http-scgi-temp-path=/var/cache/nginx/scgi_temp --user=nginx --group=nginx --with-http_ssl_module --with-http_realip_module --with-http_addition_module --with-http_sub_module --with-http_dav_module --with-http_flv_module --with-http_mp4_module --with-http_gunzip_module --with-http_gzip_static_module --with-http_random_index_module --with-http_secure_link_module --with-http_stub_status_module --with-http_auth_request_module --with-http_xslt_module=dynamic --with-threads --with-stream --with-stream_ssl_module --with-http_slice_module --with-mail --with-mail_ssl_module --with-file-aio --with-ipv6 --with-http_v2_module --with-cc-opt='-g -O2 -fstack-protector --param=ssp-buffer-size=4 -Wformat -Werror=format-security -Wp,-D_FORTIFY_SOURCE=2' --with-ld-opt='-Wl,-Bsymbolic-functions -Wl,-z,relro -Wl,--as-needed'

# 编译
make

# 安装
make install

# 添加用户和组
groupadd -f nginx  
useradd -g nginx nginx

# 测试
nginx -t

# 启动
nginx  
显示评论